Status
Get in touch
Back
Resolved
Update
Completed
2 days and 14 hours ago
.
Affected services
Bedrock Gateway
CB-1
CB-2
Farm-1
Farm-2
Completed
Maintenance ended
Posted
2 days and 14 hours ago
.
Started
Einführung eines neuen Updates auf RangeMC
Posted
2 days and 15 hours ago
.